Website outage
Incident Report for MADANA
Resolved
This incident has been resolved.
Posted Jun 11, 2019 - 16:46 CEST
Investigating
We are experiencing issues with our website and are currently looking into it.
Posted Jun 11, 2019 - 16:04 CEST
This incident affected: Community Hub and Website.