We're experiencing long latency when accessing the Community Hub
Incident Report for MADANA
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 06, 2018 - 20:00 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Nov 06, 2018 - 18:58 CET
Investigating
We are currently investigating this issue.
Posted 6 months ago. Nov 06, 2018 - 18:46 CET
This incident affected: Community Hub.